This post belongs to a parent post.

disc_cover fixed oh_edo_rocket

Edit | Respond

cd_cover has the automatic alias of dvd_cover. Should we change that so these CD covers are labeled?
There's no point in differentiating between a CD cover and a DVD cover.
Maybe we can change the name of this tag.