Checkmate said:
*****strong reason to believe this is hitting the bandwidth cap.

****we use a solid 10TB - 10.5TB / day from vnstat,
dam thats ALOT of memory XD

eitherway still love this website despite the hiccup<3
joba said:
Using google trends, the site has twice as much activity then one year ago. The pandemic really made people use internet more.
yeah its funny xfinity even upped their data cap and in my home state they increased it by like 30-40 percent XD
joba said:
Using google trends, the site has twice as much activity then one year ago. The pandemic really made people use internet more.
It has been high traffic for a long while but we've only experienced this weird packet loss slowdown since last week, and it began one day before the site crashed so it has to be related.
I'll see what I can do next for yandere. Let's say this requires some ... creativity.

Before anyone asks why the server was down few hours today, the server restarted automatically after an update. A mistake in a config prevents it from booting (it boots into rescue mode).

I'm very swamped recently, so I'm a bit slow responding to these types of outage.
Checkmate said:
I'll see what I can do next for yandere. Let's say this requires some ... creativity.

Before anyone asks why the server was down few hours today, the server restarted automatically after an update. A mistake in a config prevents it from booting (it boots into rescue mode).

I'm very swamped recently, so I'm a bit slow responding to these types of outage.
By the way the slowdowns just fixed themselves on my end after this restart lol.
em1yan said:
By the way the slowdowns just fixed themselves on my end after this restart lol.
Yes for me too, slowdown seems to be fixed.
Was 20kb/s-50kb/s with massive packet loss for the last few days to now "normal" speed again.
Checkmate said:
I'll see what I can do next for yandere. Let's say this requires some ... creativity.

I'm very swamped recently, so I'm a bit slow responding to these types of outage.
Do appreciate you getting it fixed given a busy schedule.
flandere said:
Yes for me too, slowdown seems to be fixed.
Looking good on my end too. None of the "stalls in the middle" in any of the dozen or two things I leeched today.

Thanks for fixing things!
Same for me: picture https://files.yande.re/image/ff9182d38d92b2e8f1e32099e63c49ba/yande.re%20773775%20nemuri_nemu%20seifuku%20yuri.png (8.48 MiB for the PNG version) loaded in only 2.36s.
Finally, that crash was a good thing! XD

(I was just about to post that message when the site went down:

uncard86 said:
Maybe he's talking about the allotted bandwidth for the month... We're at the end of April and we probably hit it early. 10TB a day is nothing to sneeze at and sites do get user spikes. I've recently returned this year as other sites have been bogus when it comes to High Res content.
If it’s the case, then I guess it will be back to normal starting May? Is it because Radio is uploading entire books almost each day since his comeback? (Well, I’m half-joking)
I’ve noticed the same problem with another site (San××ku Com××ex, to not name it), but it may be just a coincidence?”

But I guess this is useless, now)
This topic is way too long, and I cannot answer everything.

The bandwidth is a fixed pipe, 1Gbps, or 100MB/s, which translates to a maximum of 330TB/month at 100% utilization. Since that is not possible, a 300TB utilization is already considered full. It's like the concept of water, everyone needs water at around the same time, and we only have so much pipe capacity to carry them through to everyone.

As for the crash, it wasn't a crash. It was a scheduled server upgrade. The restart failure causes the crash because of an error in fstab config.

However, I believe the kernel was having some issues. Updating the kernel somewhat fixes the problem a bit. That or people stop their crawler for now.
US West, 3:33 AM now. The speed is pretty good like it used to be, most pictures can be loaded in seconds. Finally, get a chance to download those failed downloads in the past few days. I agree that there may crawlers filled the bandwidth and cause this slowdown.
EU Central here, speed is considerably better now, I think the server restart did something
Good here as well... I think we've all learned a valuable lesson here... Also, update and restart. :P
IT support said:
Have you tried turning it off and on again?
It's quite absurd how many technical problems can be fixed with this cliché...
I have taken a look at the update log. It seems a faulty firmware of the NIC card was causing the issue with dropping connections and a minimal packet loss. Updating its firmware seems to have fixed the issue.
Checkmate said:
I have taken a look at the update log. It seems a faulty firmware of the NIC card was causing the issue with dropping connections and a minimal packet loss. Updating its firmware seems to have fixed the issue.
Glad to know. Thank you very much! :)
Fixed for me too. Really appreciate you taking a look into this even with your busy schedule. Thanks!
@Checkmate, what about image search? Can't detect duplicate or similar image. It's also won't give "possible_duplicate" message or tags.
Image search and similar images are not available now,And I also found that since the collapse of iqdb, Saucenao can no longer search for new images uploaded to the site.
duplicate search is provided by iqdb. Iqdb is down.

Follow them for more details:

https://twitter.com/SauceNAO/status/1383592814005551109

https://twitter.com/SauceNAO/status/1379217839974973441

Create a dedicated topic for this if you want but keep these out of the current topic.
I think I may have found one the crawler(s):

https://www.reddit.com/r/DataHoarder/comments/myvd5j/boorupixiv_gallery_hoarding/

It is possible that it's people like him that wants to download the whole thing that is causing issues?
Damn,If there are more people like this, the server will become very slow again :(
The server is fast these days,Thank you for your hard work Checkmate.